Deutsch
Germany.ruФорумы → Архив Досок→ Linux & Co

Wi-Fi не работает в Kubuntu

278  
kashej местный житель20.10.14 12:33
kashej
20.10.14 12:33 
Если включаю соответствующий переключатель на ноутбуке, то горит только диод для bluetooth. Wi-Fi адаптер не горит.
Ну и соответственно чекбокс Wireless disabled серый, и галочку нельзя поставить.
Адаптер работает исправно под виндой. В чем может быть проблема?
http://denis-aristov.ucoz.com
#1 
kashej местный житель20.10.14 15:08
kashej
NEW 20.10.14 15:08 
в ответ kashej 20.10.14 12:33
Команда lspci -k выдает следующее:
В ответ на:
0c:00.0 Network controller: Broadcom Corporation BCM4321 802.11a/b/g/n (rev 03)
Subsystem: Dell Wireless 1500 Draft 802.11n WLAN Mini-card
Kernel driver in use: b43-pci-bridge

http://denis-aristov.ucoz.com
#2 
НуПогоди знакомое лицо20.10.14 16:07
NEW 20.10.14 16:07 
в ответ kashej 20.10.14 12:33
У меня аналогичная ситуация изредка возникает после выхода из сна, но не с wifi, a с mobile-соединением. Помогает простейшее перетыкивание usb-модема...
ПС. Погуглил решение для вайфая
В ответ на:
sudo rm /dev/rfkill && sudo reboot

Не помогает?
взято отсюда: Ubuntu Wireless disabled: SIOCSIFFLAGS: Operation not permitted
Rooted: Kindle 3.0.3 > Tolino Shine 1.1.1; THL T7 > Moto E4 Plus В игноре: novijpolzovatel, klepan, Счастьевдруг
#3 
kashej местный житель20.10.14 16:43
kashej
NEW 20.10.14 16:43 
в ответ НуПогоди 20.10.14 16:07
К сожалению не помогает.
А я смотрю сайт wiki.archlinux.org/index.php/Wireless_network_configuration_%28%D0%A0%D1...
Застрял там на шаге
В ответ на:
Также проверьте вывод команды ip link, чтобы убедиться, что сетевой интерфейс (обычно название начинается с буквы "w", например, wlp2s1) был создан.

У меня эта команда выдает:
В ответ на:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000
link/ether 00:1c:23:82:98:53 brd ff:ff:ff:ff:ff:ff

Очевидно, что у меня он не был создан, но там не написано, что это означает или что делать в этом случае.
Дальше написано
В ответ на:
Затем поднимите интерфейс командой ip link set интерфейс up

Поднимаю с помощью ip link set wlan0 up ну и естественно выдает ошибку Cannot find device "wlan0"
http://denis-aristov.ucoz.com
#4 
НуПогоди знакомое лицо20.10.14 19:00
NEW 20.10.14 19:00 
в ответ kashej 20.10.14 16:43
Добрался домой... Боюсь, если вайфай у вас ни разу не заработал (а не как у меня -- что-то просто не поднимается после сна), то проблема может быть в том, это броадкомовские драйвера некорректно работают с чипом. Может, имеет смысл посмотреть, чем на вашем железе пользуется windows и поискать подходящий
Скажем, у меня в ходе инсталляции mint не выбрал драйвер к вайфай-чипсету, мне пришлось его отметить самому в system settings > hardware > driver manager
ПС. Н-да, помощи от меня, похоже, мало -- и железо другое (Lenovo Ideapad G700), и дистрибутив тоже (Mint 17 KDE)... Могу разве что выложить свои логи и скрины

В ответ на:
# lspci -k
...
02:00.0 Network controller: Broadcom Corporation BCM43142 802.11b/g/n (rev 01)
Subsystem: Lenovo Device 0611
Kernel driver in use: wl
...

В ответ на:
#ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DORMANT group default qlen 1000
link/ether 9c:d2:1e:f8:9b:6b brd ff:ff:ff:ff:ff:ff
48: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000
link/ether 60:02:92:02:6d:97 brd ff:ff:ff:ff:ff:ff

ну и соответственно
В ответ на:
#rfkill list all
0: ideapad_wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
1: ideapad_bluetooth: Bluetooth
Soft blocked: yes
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
3: brcmwl-0: Wireless LAN
Soft blocked: no
Hard blocked: no
6: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no

Rooted: Kindle 3.0.3, Tolino Shine 1.1.1
Rooted: Kindle 3.0.3 > Tolino Shine 1.1.1; THL T7 > Moto E4 Plus В игноре: novijpolzovatel, klepan, Счастьевдруг
#5 
kashej местный житель21.10.14 06:54
kashej
NEW 21.10.14 06:54 
в ответ НуПогоди 20.10.14 19:00
Да, пожалуй дело в драйвере. Нашел сайт с драйверами http://www.broadcom.com/support/802.11/linux_sta.php
Скачал. Попытался откомпилировать, но оказалось, что у меня даже gcc не установлен. В общем по-моему для начала нужно хотя бы проводную сеть настроить.
Раньше уже давно это делал. Но тут сеть через VPN L2TP. Вроде уже есть готовые скрипты, которые все делают, но хотелось бы самому разобраться.
http://denis-aristov.ucoz.com
#6 
НуПогоди знакомое лицо21.10.14 13:56
NEW 21.10.14 13:56 
в ответ kashej 21.10.14 06:54
Помимо драйверов... так, на всякий пожарный: на ubuntuusers.de пишут, что на некоторых моделях dell & acer вайфаю могут гадить модули dell_wmi (возможно, ваш случай) и acer_wmi. Симптомы там описаны, так же как и решение: для нормальной работы нужно внести их в /etc/modprobe.d/blacklist.conf
Rooted: Kindle 3.0.3 > Tolino Shine 1.1.1; THL T7 > Moto E4 Plus В игноре: novijpolzovatel, klepan, Счастьевдруг
#7